Sponsors of Wiimoteproject.com
IR Pens for Wiimote Whiteboard
Wiimote ProjectWiimote ProjectsWiimote Interactive WhiteboardWiimote Smoothboard (Moderator: boonjin)Problems in Calibration WiiMote in Smoohtboard v1.0
Pages: [1] 2
Print
Author Topic: Problems in Calibration WiiMote in Smoohtboard v1.0  (Read 13156 times)
0 Members and 1 Guest are viewing this topic.
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« on: January 30, 2009, 02:02:40 PM »

Hi
sorry for my bad english, thanks for your help

I have a problem to Calibrate the WiiMote,

The wiimote comunicate with the pc,

The IR pen function correctly ( I see the IR light with a camera)

In the main window of the program when I point the IR pen in front of the screen I see the red point in the small preview window,



 but when I start the calibration It doesn't function.



I have tried the program in two different machine, with only installed Windows XP, Netframework 3.5 and Smooth board v.10 but  the calibration doesn't function

I don't know what to do...

My OS is windows XP Sp3
Blueetooth Stack is widcoom

Thanks for your Help
Logged
Guru
*****
Karma: +28/-0
Posts: 928
Online Online
Smoothboard Developer
View Profile WWW
« Reply #1 on: January 30, 2009, 02:19:39 PM »

Hi,

Does the main window always detect it as four dots?

Have you tried running it in presenter mode? and test whether the mouse moves when you try using the IR pen.

Regards,
Boon Jin

Logged

Smoothboard
Wii Whiteboard/Wiimote Whiteboard with annotation features and collaborate with multiple iPads and Android Tablets!

Smoothboard for Mac
Using a Mac? Now you can annotate on PowerPoint or Keynote slideshows!

BoonJin[/url
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #2 on: January 30, 2009, 02:50:41 PM »

Thank's for your help
In presenter mode when i move the Wii-Mote and IR-pen is stopped the mouse function correctly, The problem I believe in WhiteBoard Mode because when I start the calibration tool, remain always the firt dot to point.


This is the witheboardcalibration.dat file after the first point calibration (only for the first point because the next points doesn't appears) :

srcX[0]=0
srcY[0]=0
srcX[1]=0
srcY[1]=0
srcX[2]=0
srcY[2]=0
srcX[3]=0
srcY[3]=0
src2X[0]=0
src2Y[0]=0
src2X[1]=0
src2Y[1]=0
src2X[2]=0
src2Y[2]=0
src2X[3]=0
src2Y[3]=0
dstX[0]=102
dstY[0]=76
dstX[1]=0
dstY[1]=0
dstX[2]=0
dstY[2]=0
dstX[3]=0
dstY[3]=0

I have tried to change the position of wiimote and to reset the point dstX(o) dsty(0) at value=0 and repeat the calibration but the value of that two parameters always become dstX[0]=102 dstY[0]=76




My OS is windows XP Sp3
Blueetooth Stack is widcoom 1.4.2.10
The bluethoot device is Digicom Paladio Bluethoot 10CX
The IR led I don't khow the manufacturer because it was on an old remote

Thanks very much for your Help
« Last Edit: January 30, 2009, 03:02:03 PM by superdani884 » Logged
Guru
*****
Karma: +28/-0
Posts: 928
Online Online
Smoothboard Developer
View Profile WWW
« Reply #3 on: January 30, 2009, 02:58:09 PM »

Hi,

How is your set up of the wiimote? Did you place it sufficiently far away from the screen? As a rule of thumb, place the Wiimote 2x the height of the screen.

I suspect that the Wiimote could not capture the IR points of the corners. This is because the Wiimote's field of view is only 45 degrees. Therefore, you will have to place the Wiimote quite far away from the screen.

Regards,
Boon Jin
Logged

Smoothboard
Wii Whiteboard/Wiimote Whiteboard with annotation features and collaborate with multiple iPads and Android Tablets!

Smoothboard for Mac
Using a Mac? Now you can annotate on PowerPoint or Keynote slideshows!

BoonJin[/url
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #4 on: January 30, 2009, 03:56:14 PM »

Yes, I have placed the wiimote at 2*height of the screen, but it doesn't function;
I see on older post where there was other situations similar this, but I haven't found the solution
There is possible that is a software problem whith the calibration tool on my pc?

to show better the problem I have posted a video on youtube, now it is in elaboration, when become ready I will post the link.


Thanks



Daniele Spoladore
« Last Edit: January 30, 2009, 06:05:53 PM by superdani884 » Logged
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #5 on: January 30, 2009, 04:24:31 PM »

The video link is :

http://it.youtube.com/watch?v=xrAYKCaGi8c

Thanks

Daniele Spoladore
Logged
Support Admin
*
Karma: +49/-0
Posts: 1178
Offline Offline
benpaddlejones@live.com.au View Profile WWW Email
« Reply #6 on: January 31, 2009, 01:28:48 AM »

superdani884
Interesting!

Try:
1. move the Wiimote about 1m away from screen
2. Goto Wiimote settings make sure maximum is selected
3. Go to calibration mode point your IR-Led direct at Wiimote at about 30cm distance and click button does it rottae through the cross hairs?

What IR-Led are you using?

Ben :-)
Logged


See my full profile and links on my Google Profile: http://www.google.com/profiles/benpaddlejones
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #7 on: January 31, 2009, 02:46:13 AM »

1) Ok; I have moved the wii mote 1 m from screen
2) Ok;  maximum is selected
3) When I start the calibration if I point the Ir led direct at Wiimote at about 30cm distance, the calibration screen do nothing, remains locked at the first cross. I don't know the manufacturer of my Ir-LED because I found it on old VCR remote.
However when I start the ir-led, red dot appear in main preview screen of the program, in presentatin mode the IR function OK
In the Whiteboard mode, When I start the calibration I believe that the wiimote stop the comunication whith the software calibrator, because If i point the IR-pen diretly if front of wii mote, nothing changes in calibration screen.

I'm very interested at this project, but I don't know how to solve this problem...

thank's very much

Dani   
Logged
Support Admin
*
Karma: +49/-0
Posts: 1178
Offline Offline
benpaddlejones@live.com.au View Profile WWW Email
« Reply #8 on: January 31, 2009, 04:13:04 AM »

Dani
I think it is your IR-Led, ones from TV remote don't operate in the correct wavelength (940nm).

1. Try setting up so you can see the sun (direct no window, clouds etc).
2. Start calibration and point your wiimote direct at the sun.
3. Wave it arround

If it steps through the calibration then its your IR-Led.

benpaddlejones Smiley

Logged


See my full profile and links on my Google Profile: http://www.google.com/profiles/benpaddlejones
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #9 on: January 31, 2009, 04:22:09 AM »

Thanks, tommorow I will try ( I live in Italy and now are 2.22 AM and there isn't sun.. Smiley )
I also triing to install more recent widcoom bluetooth driver, because the version now installed is too old ( 1.4.2.10 )

I will post the result tomorow

thanks

Dani
Logged
Guru
*****
Karma: +28/-0
Posts: 928
Online Online
Smoothboard Developer
View Profile WWW
« Reply #10 on: January 31, 2009, 05:11:13 AM »

Thanks for the video.

It looks like there are other IR sources detected by the Wiimote during the whole duration.

The number of dots detected (written at the bottom of the main window) should be empty when you are not pressing the IR pen.

Logged

Smoothboard
Wii Whiteboard/Wiimote Whiteboard with annotation features and collaborate with multiple iPads and Android Tablets!

Smoothboard for Mac
Using a Mac? Now you can annotate on PowerPoint or Keynote slideshows!

BoonJin[/url
Support Admin
*
Karma: +49/-0
Posts: 1178
Offline Offline
benpaddlejones@live.com.au View Profile WWW Email
« Reply #11 on: January 31, 2009, 07:13:05 AM »

superdani884
Boonjin, your right! I didn't look that close, maybe too much sun light in your room.

Read this to understand: http://www.boonjin.com/smoothboard/index.php?title=IR-Camera_Sensitivity

I also suggest if your current stack is working with no connectivity problems DO NOT change it! The latest version of Widcomm has had particular inconsistencies with the Wiimote.

If anything I would do the MS stack hack: http://www.shootingsoftware.com/Widcomm.htm

benpaddlejones Smiley
Logged


See my full profile and links on my Google Profile: http://www.google.com/profiles/benpaddlejones
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #12 on: January 31, 2009, 02:55:07 PM »


Hi Boonjin, Ben,
thanks for your help,
today in my county the weather is cloudy, i can't try to point the wiimote in front of the sun  Sad


It looks like there are other IR sources detected by the Wiimote during the whole duration.

The number of dots detected (written at the bottom of the main window) should be empty when you are not pressing the IR pen.


There aren't other IR-sources when the pen is off. To make that video I used the camera inside my cellular, the sun light effect is caused by flash of phone reflected on the surface of the screen. In normal condition, there isn't sun light effect.  My question is: if the IR-led function correctly in presentation mode and with other application and in witheboard mode when I start the IR-Led,  I see the red dot in preview window, how is possible that the problem is the IR-Led or light enviroment?
 
Thanks very much
I will hope to compensate your kindly avaiability.

Dani
Logged
Guru
*****
Karma: +28/-0
Posts: 928
Online Online
Smoothboard Developer
View Profile WWW
« Reply #13 on: January 31, 2009, 03:01:20 PM »

Hi Dani,

Do you mean that when you activate the IR pen, there will be 4 IR dots shown always?

The whiteboard mode will not function correctly if there it registers as such.

You encountered the same problem on two different machines?

Regards,
Boon Jin
« Last Edit: January 31, 2009, 03:05:07 PM by boonjin » Logged

Smoothboard
Wii Whiteboard/Wiimote Whiteboard with annotation features and collaborate with multiple iPads and Android Tablets!

Smoothboard for Mac
Using a Mac? Now you can annotate on PowerPoint or Keynote slideshows!

BoonJin[/url
*
Karma: +0/-0
Posts: 11
Offline Offline
View Profile
« Reply #14 on: January 31, 2009, 04:00:59 PM »

Hi,
probably I was misunderstanding because mi english in not good.
When I activate the IR pen, in the preview screen in main window program there is only one red circle point.

I have the same problem in calibration with 3 different machine and with 2 different bluethoot adapter.

I used the camera only to make the video on youtube, but in normal condition I dont' use the camera.

Thanks

Dani
Logged
Pages: [1] 2
Print
Jump to:  

Clicky Web Analytics