Author Topic: 2 Wiimotes under the same name  (Read 6420 times)

Offline Raptor007

  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
on: March 14, 2009, 02:33:23 PM
I am having problems connecting two wiimotes at the same time. I can connect one and it comes up as the normal name.

Then Smoothboard can start and everything works great.

I connect a second wiimote and it comes up as the same name (Nintendo RVL-CNT-01) under the bluetooth listing.

I then can run Smoothboard and it will only use the second wiimote, still working but only with one wiimote. The second wiimote has one light on (far left), the same as the first one connected.


My bluetooth adapter is a Cirago BTA-3210. Using Windows Vista x64

This problem occurred under both the Microsoft stack and the Toshiba stack which I am now using.

I tried resyncing both wiimotes to my wii console with no luck. I also went through and did the driver update under device manager.

This is such an awesome project any help would be great. Thanks.


I attached two screen shots of the connected screens.



Offline benpaddlejones

  • Support Admin
  • *
  • Posts: 1178
  • Karma: +49/-0
    • View Profile
    • Inter.Connect.Ed
Reply #1 on: March 14, 2009, 03:40:42 PM
Raptor
Try connecting your two wiimotes to a another system. Its the Wiimote that sends the identifyer, not the stack. (I wonder if it could be a 64bit thing too.). If they connect fine on another system let me now and I'll have a deeper thought.

Sorry to ask a dumb question in your time of need, but...
My toshiba stack help guide is in need of some accurate info. Could you please have a look at http://www.boonjin.com/smoothboard/index.php?title=Connecting_to_the_Toshiba_Bluetooth_stack and confirm my sequence is correct and some screen dumps of teh process would be cool too.

benpaddlejones :)


See my full profile and links on my Google Profile: http://www.google.com/profiles/benpaddlejones


Offline Raptor007

  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Reply #2 on: March 16, 2009, 11:50:51 AM
Thanks for the response. I tried to connect to one laptop this weekend but ran into other troubles.

I will be trying to connect other wiimotes to my system this week and hopefully find another laptop with bluetooth to connect my wiimotes to.

I'll take a look at the guide. Used it myself, so would be glad to help. I will post the screens in this thread as a attachment if that works this week.

Could you point me in a direction to figure out more what determines the Wiimote's Bluetooth name. Is it by what number it is synced to? Or if I switched my wiimote with someone else's would they both be one?



Offline Raptor007

  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Reply #3 on: March 24, 2009, 08:38:43 PM
No luck with getting other wiimotes so I can try to connect them. I did get data using the example code for the wiiuse library, but IR data doesn't work on whatever wiimote was connected first. Roll and button presses work fine though.

I did have time to look at the Toshiba procedure. I guess I will post some changes here.

2. Click 'Create a new connection'  should be 2. Click 'New connection'

Although for me it comes up automatically.

There are some screenshots of the couple windows from steps 5 to 8. Odd numbering too. I attached them since I didn't know where else to put them. (The screen shot of onewiimote from my first post could work too).

I never get a disconnect from a timeout between adding a new wiimote and opening smoothboard either.

Reconnecting looks fine, I just added a screenshot of it.

Mostly nick-picking stuff, the guide helped me for the first time, but feel free to use the screens if you want.