Author Topic: SOLVED - This device cannot start. (Code 10) - Please help :-)  (Read 36660 times)

Offline eureka345

  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Hi everyone -

I finally got my bluetooth adapter to install, and BlueSoleil now recognizes my wiimote and I can get it to the point where it's got the green connection, the blue leds on the wiimote keep flashing, etc. 

When I go to start the Wiimote Whiteboard program, I get the Wiimote not found in HID device list error.

When I open my device manager, I see the wiimote in the HID device list, but with an exclamation point and the This device cannot start. (Code 10) message. 

I am running Windows Vista on a Toshiba A200 laptop, with an IOGear USB dongle (GBU241W6) and BlueSoleil 3.2.2.8 Release 070421 Stack version 06.03.29.20061212

Any suggestions???

I am running this project in my grade nine computers class.. they are fascinated by the whole process and are very anxious to see it working :) 
« Last Edit: January 05, 2009, 05:57:30 AM by benpaddlejones »



Offline benpaddlejones

  • Support Admin
  • *
  • Posts: 1178
  • Karma: +49/-0
    • View Profile
    • Inter.Connect.Ed
Reply #1 on: September 22, 2008, 08:12:02 PM
eureka345
Try updating the HID drivers (right click on all HID's then selct 'update driver')

If that fails delete teh HID & start again

You may experience 'the blue screen of death' this was a fault with early versions of Bluesoleil, requiring you to update to the latest version http://www.bluesoleil.com.

Otherwise try this: http://www.wiimoteproject.com/wiimote-and-bluetooth-connectivity/finally-a-fix-for-bluesoleil-usb-bluetooth-stop-bluesoleil-crashing-your-comp!/ better still try removing all bleusoleil, then just insert your USB, if its compataible with Windows BT drivers they will automatically load. You can then use Thex's Wiimote Connect a really easy to use connection utility.

Benpaddlejones :)


See my full profile and links on my Google Profile: http://www.google.com/profiles/benpaddlejones


Offline eureka345

  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Reply #2 on: September 22, 2008, 08:18:48 PM
Thanks so much for your prompt reply.

I clicked update drivers, as you suggested, and it says they are up to date.  The wiimote is the only HID I have, so it's the only one in there.  The exclamation point still remains.

I also tried deleting/uninstalling the HID from the device manager list... same issue after it is reinstalled. 

I am not experiencing any crashing or blue screens of death, so I'm not sure how the other suggestions apply? 

Edited to add:  Any other information I could provide to bring clarity on the situation?
« Last Edit: September 22, 2008, 08:20:43 PM by eureka345 »



Offline eureka345

  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Reply #3 on: September 24, 2008, 05:59:57 PM
I've discovered that, among other things, I have a defective adapter.  Off to exchange it and try again.  Thanks for your help... I'll let you know how it all works out.  I have my entire faculty asking for updates constantly!!



Offline UndCon

  • Support Admin
  • *
  • Posts: 566
  • Karma: +11/-3
    • View Profile
    • UndCon
Reply #4 on: September 25, 2008, 01:02:39 AM
I bet it has something to do with your faulty equipment...

Error 10 is something I haven't seen since I used Windows98 :D



Offline eureka345

  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Reply #5 on: September 27, 2008, 02:25:57 PM
Success!  It was definitely a defective adapter.  Bought a new one last night, plugged it in about 10 minutes ago and voila.. already connected.  I'm just mad I spent so much time trying in vain to force the other one to work!  :)  Oh well.

Now to find an IR pen.  I had made one, but sometime in between making it and fighting with my bluetooth, it doesn't work anymore.  Eventually, eventually, this will all come together :)



Offline UndCon

  • Support Admin
  • *
  • Posts: 566
  • Karma: +11/-3
    • View Profile
    • UndCon
Reply #6 on: September 30, 2008, 12:56:03 AM
I wish you good luck!