Wiimote Project

Hardware Support => Bluetooth & Connectivity Help Center => Topic started by: VKScott on August 03, 2011, 01:20:45 AM

Title: Wiimote not Connecting
Post by: VKScott on August 03, 2011, 01:20:45 AM
Thanks in advance to anyone who could help me out with this. I'm trying to get it working for my wife's classroom.

•Operating System: Windows 7 32-Bit
•Bluetooth Stack: Windows Default
•Bluetooth Stack version:Not sure how to find this
•Connection Method using: Tried WiimoteConnect v. 0.6, SmoothConnect, and connecting manually.
•Detailed description of what happens: The first time I ever tried to connect with WiimoteConnect, it connected perfectly and ran with all the programs I wanted. Then, ever since, it simply won't connect. When I use WiimoteConnect, the HID drivers appear and the program gives me the "1 Wiimotes successfully connected message." Then, after a few seconds, the drivers disappear from the Device Manager. The same happens when I try to manually connect, and nothing happens at all when I use SmoothConnect.
•A screen dump of your device manager (Bluetooth Devices & Human Interface Devices expanded)

I've attached shots of my device manager. The first file is immediately after the Wiimote "connects." #2 is approx. 3 seconds after that, and then thirty seconds later I get the third image.

Any help would be appreciated!
Title: Re: Wiimote not Connecting
Post by: VKScott on August 03, 2011, 01:22:05 AM
Looks like I didn't attach the images. Let's try that again...
Title: Re: Wiimote not Connecting
Post by: boonjin on August 03, 2011, 03:40:01 AM
Hi,

As you are using Windows 7, you may need to disable the Windows Update for device installation as shown here: http://www.smoothboard.org/manual/Common%20Issues.htm#_Toc274086162 (http://www.smoothboard.org/manual/Common%20Issues.htm#_Toc274086162)

For your case, most probably the Wiimote stops its discovery mode before the operating system manages to connect to it due to the time it takes for the Windows Update. Following the previous instruction should the connectivity issue.

Regards,
Boon Jin
Title: Re: Wiimote not Connecting
Post by: VKScott on August 03, 2011, 08:17:09 AM
Boon Jin,

Thanks for the quick reply!

When I went to change that option, it was actually already on "Never install device drivers from Windows Update." I changed it to the second one, that you referenced, but I'm still having the same problem.

Any other ideas?
Title: Re: Wiimote not Connecting
Post by: boonjin on August 03, 2011, 09:52:19 AM
Is there anything shown in the system tray during the connection process?

What Bluetooth adaptor are you using?

Regards,
Boon Jin
Title: Re: Wiimote not Connecting
Post by: VKScott on August 03, 2011, 02:23:10 PM
Is there anything shown in the system tray during the connection process?

What Bluetooth adaptor are you using?

Regards,
Boon Jin

Two balloons pop up: "Installing device driver software," then "Bluetooth HID Device, Device driver software installed successfully."

I'm using the internal bluetooth device that came with the laptop.

And, of course, that time when I performed the connection to see what popped up, the darn thing worked.

I'm not sure what I did differently. I'll let you know if it continues to connect sporadically, but if it doesn't work again the next time I load it up, do you have any suggestions? My main concern is that this is for use in my wife's classroom, and when she needs to use it she won't have the time to troubleshoot it if things go wrong.
Title: Re: Wiimote not Connecting
Post by: boonjin on August 03, 2011, 09:08:01 PM
Just to check with you, are you using an original Wiimote?

Also, you may want to try reinserting the batteries and use the Red Sync button to connect the Wiimote.

Regards,
Boon Jin