Wiimote Project

Hardware Support => Bluetooth & Connectivity Help Center => Topic started by: niceified on July 31, 2011, 02:32:57 PM

Title: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on July 31, 2011, 02:32:57 PM
I'm having trouble getting my wii remote working.
I'm using Windows 7 64-bit on a Mac Mini via bootcamp, with the built-in bluetooth adapter. I'm currently trying the MS stack, but I've also tried BlueSoleil and widcomm. Once I add the device, the lights keep continuously blinking, but most apps do not see the remote. Smoothboard seems to see it but gives the message: "Error reading data from Wiimote...is it connected?" One time Smoothboard actually connected, but it hasn't happened again, and I didn't do anything differently.
I know the adapter works, because it works fine in OS X with Wiiji and Darwiinremote.

Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on July 31, 2011, 07:36:47 PM
Have you tried connecting the Wiimote with Smoothboard's SmoothConnect?

As you are using Windows 7, you may need to disable the Windows Update for device installation as shown here: http://www.smoothboard.org/manual/Common%20Issues.htm#_Toc274086162

You may want to try with an external Bluetooth adaptor too as the built-in adapter might not be able to connect to the Wiimote in Windows.

Also, if you are using a Mac, you can actually use Smoothboard for Mac. The Smoothboard for Mac software can be downloaded from http://www.smoothboard.org/mac (http://www.smoothboard.org/mac)

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 01, 2011, 06:19:18 AM
Yes, I've tried SmoothConnect. It worked one time, and wouldn't work again.
I've already disabled the Windows Update, but it didn't help.
The Mac version of Smoothboard works fine. I was just trying the Windows version to see if it would see the Wiimote, since no other Windows programs are able to.

As for using an external Bluetooth adapter, are there any particular ones that are known to work in Windows 7 64?
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 01, 2011, 09:19:03 AM
Yes, I've tried SmoothConnect. It worked one time, and wouldn't work again.
I've already disabled the Windows Update, but it didn't help.
The Mac version of Smoothboard works fine. I was just trying the Windows version to see if it would see the Wiimote, since no other Windows programs are able to.

As for using an external Bluetooth adapter, are there any particular ones that are known to work in Windows 7 64?

What happens when you are trying to connect with SmoothConnect?

The Mini Bluetooth Adaptor sold by our resellers should work well.

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 01, 2011, 12:57:44 PM
When I try to connect with SmoothConnect, it says 1 found 1 connected, and the LED lights up. But then when SmoothBoard starts, it says, "Error reading data from Wiimote...is it connected?"
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 01, 2011, 07:13:20 PM
When I try to connect with SmoothConnect, it says 1 found 1 connected, and the LED lights up. But then when SmoothBoard starts, it says, "Error reading data from Wiimote...is it connected?"

It seems that the HID device for the Wiimote may be not be installed correctly.

Have you tried connecting any other Bluetooth devices in the Windows of your Mac?

For my own Macbook, I am actually using an external Bluetooth adaptor too when using Windows.

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 01, 2011, 08:54:10 PM
It seems that the computer is able to send data to the Wiimote, it just can't receive any data back:

I was playing around with WiimoteTest that is included with Wiimotelib, and as expected, it did not respond to any button presses on the Wiimote. However, the options to activate the rumble and LEDs worked. Very strange.
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 01, 2011, 09:22:09 PM
It seems that the computer is able to send data to the Wiimote, it just can't receive any data back:

I was playing around with WiimoteTest that is included with Wiimotelib, and as expected, it did not respond to any button presses on the Wiimote. However, the options to activate the rumble and LEDs worked. Very strange.

Yeah, this is most probably caused by a faulty connection or driver installation. As you have mentioned the Wiimote and Bluetooth adaptor works in the Mac OS, most probably it is a driver issue.

Also, you may want to try reinserting the batteries and press the Red sync button.

If it still fails, it may be easier to use an external Bluetooth adaptor.

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 06, 2011, 09:21:06 PM
I've purchased an external Bluetooth adapter from irgreat.com, but Windows keeps using the built in one.
I've tried disabling the built in adapter, but then the Bluetooth icon disappears from the system tray. Also, it makes the Microsoft Bluetooth Enumerator disappear from the device manager.
Do I need to install some software for this to work?
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 07, 2011, 08:16:36 AM
Hi,

After disabling the built-in Bluetooth, plug the external dongle again.

If the MS Bluetooth Stack icon does not appear, you may want to try using the tool from www.bluetoothinstaller.com (http://www.bluetoothinstaller.com)

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 07, 2011, 06:29:55 PM
I finally got the dongle working by changing the driver from "CSR Bluetooth Device" to "Generic Bluetooth Adapter" in device manager. Now the Microsoft stack is installed and the Bluetooth icon is back.
Unfortunately, it's acting the same way that the built in one does: Windows can see the Wiimote, but apps are unable to use it.
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 08, 2011, 12:57:39 AM
I finally got the dongle working by changing the driver from "CSR Bluetooth Device" to "Generic Bluetooth Adapter" in device manager. Now the Microsoft stack is installed and the Bluetooth icon is back.
Unfortunately, it's acting the same way that the built in one does: Windows can see the Wiimote, but apps are unable to use it.

Hi,

Are you running the Windows 7 in Mac Bootcamp or a virtual machine?

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 08, 2011, 04:26:07 AM
I'm running it in bootcamp.
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 08, 2011, 09:13:03 PM
I'm running it in bootcamp.

Does SmoothConnect appear when you launch Smoothboard? If you are not using SmoothConnect, you may need to remove the Wiimote device each time before connecting again.

Maybe you can describe in more detail the observation during the connection process too.

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 09, 2011, 08:39:50 AM
Yes, Smoothconnect appears when I launch Smoothboard.
I've attached some screenshots of what usually happens when I run Smoothboard.


Strangely, this morning when I ran Smoothboard, it actually connected and worked fine. But then when I tried to do it again later, it didn't work. I tried unplugging and removing the dongle, deleting the wiimote device, and even restarting the computer, but it didn't happen again. Seemed kind of random.
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 10, 2011, 10:16:16 PM
I've finally found a way for Smoothboard to work.
If I take out the Wiimote's batteries and replace them every time, then Smoothboard is able to connect to the Wiimote just fine. However, other software still is not able to use it.
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: boonjin on August 11, 2011, 07:19:23 PM
I've finally found a way for Smoothboard to work.
If I take out the Wiimote's batteries and replace them every time, then Smoothboard is able to connect to the Wiimote just fine. However, other software still is not able to use it.

That is weird. After replacing the battery once, have you try reconnecting like normally (without reinserting again)?

Also, have you tried the Red Sync button to connect instead of the 1+2 buttons?

Regards,
Boon Jin
Title: Re: Wiimote not working in Win7x64 on Mac Mini
Post by: niceified on August 11, 2011, 10:52:47 PM
Using the sync button seems to work most of the time. Sometimes I still have to take out the battery though.


As for using other software, after many hours of messing around with things, I think I finally found a solution:
First I open GlovePIE. I then open my script and press Run.
Then I put the Wiimote into discovery mode and connect the usual way.( In the Bluetooth control panel)
The Wiimote will seem to be connected for a moment, but then its icon will have a yellow exclamation mark on it. After a second, it disconnects and the icon disappears. I then put the Wiimote back into discovery mode and connect again in the usual way, and this time it works.
It's weird that I have to do all that, but at least it's working now.