Wiimote Project

Hardware Support => Bluetooth & Connectivity Knowledge Center => Topic started by: shadowbyrn on January 09, 2010, 09:44:47 AM

Title: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: shadowbyrn on January 09, 2010, 09:44:47 AM
After searching, and searching, and seeing SOOOOO many people with the same problem as me, I was randomly picking at my Wiimote trying to get it to connect with the latest Broadcom drivers.  Here is what I found:

I found how to SKIP PAIRING.

It is almost insultingly simple.  When it asks for a passkey...press alt+s.

Enjoy!
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: MudRat02 on January 11, 2010, 11:01:45 AM
...and now I can use my wiimote.  Legendary find!   ;D
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: benpaddlejones on January 11, 2010, 05:03:57 PM
shadowbyrn

Brilliant, I'll add it to the knowledge base.

:-)
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: imswellthanks on February 19, 2010, 07:06:51 PM
Just posting to confirm this works with the Widcomm 5.5 stuff that came with my Iogear GBU421.  Hopefully that will help all the people searching for it to end up here.

My previous workaround was to programmatically force the Next button to be re-enabled (using AutoIt) - yours is far and away a superior solution!
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: ErniFusio on February 26, 2010, 06:38:39 AM
Yeaaaaaaaaaaaaaaaaaaah!!!!

Just registered to say thanks!!!!

Works for my Belkin f8t017ne

By the way, how did you figure it out????
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: dlnsk on May 03, 2010, 07:12:58 AM
I understand that it was a shortcut that is manifested by underlined when you press Alt.
This does not work in Russian. This does not work even if the Russian keyboard shortcut pressed.
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: boonjin on May 03, 2010, 08:04:48 AM
I understand that it was a shortcut that is manifested by underlined when you press Alt.
This does not work in Russian. This does not work even if the Russian keyboard shortcut pressed.

Hi,

Most probably it is not a visible button on the screen but a hidden shortcut. On your keyboard, how do you usually trigger the shortcuts? Alternatively, you can install another Widcomm version or remove it completely and use the default Microsoft Blutooth stack.

If you are using the Microsoft Bluetooth Stack, then you will be able to automatically connect the Wiimote with Smoothboard.

Regards,
Boon Jin
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: cze on June 07, 2010, 07:02:05 AM
just a short note: i was using a little i-tec usb dongle with broadcom v. 5.1.0.2400. the button to skip was clickable, but did not function. there is a simple solution: do not scan the bt environment, but manually select add device, then choose hmi device, then press 1+2, select the nintendo thing, and it will pair without the need to enter a secret code, i.e., without the need the skip at all. i suppose this variant will work with other driver versions as well. good luck!
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: agwellin on June 12, 2010, 09:30:53 PM
Hello shadowbyrn!  Just registered to let you know that you are a god among men!  

Oh, and thank you!  ;)
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: lcoreyl on September 15, 2010, 12:19:19 AM
Maybe my lack of thorough research here is making miss some reason you would want widcomm, so if there is a reason out there then this is not for you.  If you are just a general user and looking for the most simplistic way to set up a wiimote whiteboard, then I'm going to re-iterate what the real god Boon Jin just said--uninstall widcomm and bluesoleil leaving just the basic MS stack.  Then use smoothconnect. 

At my high school, my robotics team is building the IR pens/stands, ceiling mounts, switches, etc. then we sell the hardware + service to teachers and go install it for them.  Teachers, in general, are not tech savvy.  I posed the challenge to the team that we MUST have a very simple solution for teachers.  Here's what they have to do:
1) flip a switch on the wall
2) open smoothboard
3) use interactive whiteboard

Boon Jin, you are the man!!!
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: boonjin on September 15, 2010, 03:09:17 AM
Great to hear that.

The Microsoft Bluetooth Stack indeed works the easiest with Smoothboard. :)

Regards,
Boon Jin
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: gosseyn on October 12, 2010, 03:16:56 AM
hello,

i bought a bigben wiimote and nunchuck 3 days ago, and since then i tried to make it work in xp pro sp3 with the belkin bluetooth dongle(F8T017) i also bought. I was so happy when i saw the solution here, but unfortunately it seems that  "alt+s" doesn't work for me (i installed latest drivers from belkin website). I also tried to make it work with the xp built-in bluetooth support, but with no success(also tried bluesoleil but the dongle is not recognized, and with some tweaking in the usb driver files it is recognized but for like 2 sec). Anyone can help please?

to cze : where do you go to manually add hmi device?

Thanks a lot!

Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: boonjin on October 12, 2010, 06:05:29 AM
hello,

i bought a bigben wiimote and nunchuck 3 days ago, and since then i tried to make it work in xp pro sp3 with the belkin bluetooth dongle(F8T017) i also bought. I was so happy when i saw the solution here, but unfortunately it seems that  "alt+s" doesn't work for me (i installed latest drivers from belkin website). I also tried to make it work with the xp built-in bluetooth support, but with no success(also tried bluesoleil but the dongle is not recognized, and with some tweaking in the usb driver files it is recognized but for like 2 sec). Anyone can help please?

to cze : where do you go to manually add hmi device?

Thanks a lot!

Did you purchase a non-genuine Wiimote? If so, the connection to the computer may be unreliable.

Also, have you tried using Smoothboard's SmoothConnect to connect the Wiimote when you are using the Microsoft Bluetooth Stack?

Regards,
Boon Jin
Title: Re: Broadcom 5.5.0.XXXX Connection SOLVED!
Post by: gosseyn on October 12, 2010, 06:22:10 AM

Did you purchase a non-genuine Wiimote? If so, the connection to the computer may be unreliable.

Also, have you tried using Smoothboard's SmoothConnect to connect the Wiimote when you are using the Microsoft Bluetooth Stack?

Regards,
Boon Jin

Well, the wiimote is not from nintendo, it is from bigben, a well known nintendo accessories manufacturer. The wiimote worked well with bluesoleil v.8(latest), but it is shareware and disconnects the wiimote after 2mb of transfers. I played a bit with halflife 2 and glovepie.

I also tried the microsoft stack, but in my experience(and its not much), its the worst, because my belkin dongle is not recognized by windows, so it doesn't really work, (even after these manipulations http://www.shootingsoftware.com/Widcomm.htm). I have the microsoft stack control panel, but the wiimote can't be found(and other problems where i can't save settings).

So, i think the best solution for me would be to use widcomm/broadcom, but i am stuck when asked for the pairing code. Maybe the alt-s tip doesn't work because i have to use an earlier version of widcomm? (i use 5.5.0.3200). i also tried alt+i ("ignorer" instead of skip, because my OS is french).

Thanks for the help.