Wiimote Project

General Wiimote and Technology => Mac OS => General Software Talk => Connectivity => Topic started by: jdkunesh on August 19, 2009, 01:10:12 AM

Title: Mac connection issues
Post by: jdkunesh on August 19, 2009, 01:10:12 AM
I have a setup of:


Basically, everything connects pretty well. It's more the resolution that is a concern. Using one wiimote pointed at my laptop screen, I still get everything from the cursor moving a consistent, large distance (2-4 inches) away from my pen, to an intermittent pickup of the signal, making something like writing a zero or drawing a circle difficult.

Is this to be expected? We've tried just about every placement from 15cm/6 inches to 2m+/7ft+ and have had maddeningly inconsistent results. We have had better luck turning the pen around to face a rear mounted wiimote. Any feedback on best practices would be welcome.
Title: Re: Mac connection issues
Post by: benpaddlejones on August 19, 2009, 05:25:54 AM
jdkunesh
This is likely a IR-Led and surface issue. Either your IR-Led is porr quality or possibly the surface has too much glare and the Wiimote is actually tracking the reflection.

benpaddlejones :)
Title: Re: Mac connection issues
Post by: jdkunesh on August 19, 2009, 11:45:06 PM
Thanks, benpaddlejones, for the quick response!

One of our surfaces is pretty glossy (whiteboard-painted wall), but the other surfaces were a laptop screen and a monitor.

I tried with both of our penteractive pens, but neither made a difference.

I was wondering if you could share how you knew these issues might be the cause of the problem. When I do the IR Camera Monitor, none of the circles (1) (2) (3) (4) are anywhere near the pen-tip. Is that a symptom of the same problem?

Thanks again!
Title: Re: Mac connection issues
Post by: benpaddlejones on August 20, 2009, 03:15:34 AM
jdkunesh
Sounds like its either a dodgy Wiimote or you have alot of radient IR light in the room, lots of sunlight perhaps:

benpaddlejones :)