Author Topic: python-whiteboard on slackware linux  (Read 10044 times)

Offline ros

  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
on: December 06, 2011, 01:43:38 AM

for the sake of completion I thought I should try python-whiteboard, especially as it seems to be more actively developed than gtk-whiteboard (see my post on 3rd December

So I installed python-whiteboard on my linux laptop (slackware 13.37, 3.1.1 kernel, 32 bit, for those who are interested), discovered I needed numpy, so I installed that, and the program ran. I pressed 1+2 when required, and (unlike gtk-wb) the wiimote vibrated when contact was made.

Then my whole screen went white, with 4 x - one in each corner, the top left having a red square around it. In the middle of my screen was a smaller box, very similar to this one which I'm writing in, and at the top in the middle, a message about making something larger or smaller.

I took my tv remote (which had worked with gtk-wb) and tried to calibrate the top left corner, but nothing happened. I clicked furiously at various points on the screen, and in desperation turned the tv remote directly to the wiimote, but nothing.

It crossed my mind that suddenly all the batteries on the wii/tv motes had died, so I killed X (I couldn't get the program to terminate otherwise - the normal <ctrl>-C didn't work), logged in again and tried gtk-wb. It was fine.

Apart from the fact that for some reason it doesn't seem to work on my setup, the other issue is that I can't get the program to terminate without killing my X-server, because it takes over everything.

Have I done something wrong? Missed a step or something. I must confess that I'm quite new to this game. I googled a bit and discovered what might be a similar problem with Mandriva - here is a link:
I start it from the command line, but as soon as contact is made, I can't see my terminal anymore anyway. And I don't know enough about python to start fiddling with the code.

I'm quite happy to explore the world of interactive whiteboards with gtk-wb, but it would be rather satisfying to have tried python-wb as well... so any advice or help would be appreciated.


Offline 01ivier

  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Reply #1 on: December 14, 2011, 07:52:18 AM
Just to say that I get the  same issue (need to kill X-server) on an Ubuntu 10.04 with the python-whiteboard_0.9.9_all.deb but with the python-whiteboard_0.8.7_all.deb it seems to work fine...

I hope it will help you.