Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ddfire

Pages: 1
1
Bluetooth & Connectivity Knowledge Center / Re: Wiimote + Linux + apps
« on: March 06, 2008, 11:58:41 PM »
look a the bottom of the main page there is a linux section.

and you can buy a bluetooth adapter for a few bucks.

David

2
hi
i have found the solution to get all the proyect working on vista and maybe XP.


all the projects (or all the i saw)
have their own implementation of the wiimotelib
there is the problem!!! i recompiled the wiimotelib from codeplex (http://www.codeplex.com/WiimoteLib) adding the metod getbatterylevel and changing one line
public event WiimoteChangedEventHandler WiimoteChanged;
to
public event WiimoteChangedEventHandler OnWiimoteChanged;

and then i recompiled the project using that library instead the embebed one.

David

3
hi
i have the solution!!!!
i have the program running, and maybe is the solution for all the other programs!!!!

is very simple.

i downloaded the source code of the wiimotelib from http://www.codeplex.com/WiimoteLib
then

first i changed the line

public event WiimoteChangedEventHandler WiimoteChanged;
to
public event WiimoteChangedEventHandler OnWiimoteChanged;

then i added the metod GetBatteryLevel() (i take it from the wiidesktopvr wiimotelib implmentation)

then
i get the source code of the wiidesktopvr and i removed the wiimotelib implmentation from the reference and added the recompiled one (see above)   

and it si working now!!!!!
where i can submit the code and the exe????

David

i have attached the source code and in the folder release you can find the working exe.
remeber disable desktop composition. and play whit the options in the same window


4
hi
i have the same problem.

so far i see this
if i take the baterys off and put them again the wiimote works!!!! whit the WiimoteTest wich came with  WiimoteLib_1.2.1.
it work perfect until i start WiinRemote. if i close wiimotest first i have the same results.
and i was able to have two wiimotetest running at the same time whit out any problem.
when it stop working i take the batterys put them and wiimotetest work again.

i am running vista home premium. on a laptop, TX1030LA.

maybe wiinremote and the other software are sending some buggy command to the wiimote???
thanks
David


Pages: 1