Author Topic: Error reading data from Wiimote...is it connected?  (Read 7725 times)

Offline Grimface

  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
on: January 13, 2008, 09:17:41 AM
Hi,
I'm getting this error when I try and run the DesktopVR program. I've tried running the compiled program as downloaded, and also running it in Visual Studio, but get the same error in both. It seems that it can find the Wiimote, but not read from it.

I can run the simple Wiimote test program with no errors (again, in Visual Studio), so am a bit puzzled as to what's wrong.

For reference, I'm using a MacBook Pro, with Windows XP (Sp2). DirectX SDK (april 2007) and Visual C# 2008 Express. I've done some C# before, but figured it was worth asking if anyone else had experienced and overcome this problem, before spending possibly hours trying to debug it.

Thanks in advance for any help,

Jeremy (Grimface)



Offline atomriot

  • *
  • Posts: 177
  • Karma: +16/-0
    • View Profile
Reply #1 on: January 13, 2008, 10:54:44 AM
there is a difference in the connect method between johnnys app and the lib test app. if you alter johnnys app to look like the wiilib then it should work for you. i have posted the changes in the whiteboard sections

http://www.wiimoteproject.com/wiimote-whiteboard/wiimote-whiteboard-faq-and-adv-discussion-t2.0.html
 

Details, details. Things to do. Things to get done. Don't bother me with details, just tell me when they're done.
--
James Lionel Price



Offline Grimface

  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Reply #2 on: January 13, 2008, 02:29:46 PM
Thanks for the reply. Commenting those lines out worked a treat!



Offline Emlett

  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Reply #3 on: December 19, 2008, 09:45:11 PM
I currently have the same error and the link provided doesn't work anymore considering this is an old thread. My wiimote currently works with whiteboard but not with desktopvr, giving me the same error as the one shown in the title. Is there a possible fix for this?

notes: I'm on Vista 32-bit. direct X is installed. SDK is installed, etc. the wiimote is connected and able to calibrate with the whiteboard program. I start off by syncing my wiimote with the computer and then opening up whiteboard to calibrate it. Then, i open up desktopvr and receive the error.
« Last Edit: December 19, 2008, 09:48:49 PM by Emlett »



Offline atomriot

  • *
  • Posts: 177
  • Karma: +16/-0
    • View Profile
Reply #4 on: December 20, 2008, 09:54:36 AM
did you alter the code for the whiteboard app?

the new link is here

Details, details. Things to do. Things to get done. Don't bother me with details, just tell me when they're done.
--
James Lionel Price