Author Topic: Issues Creating Illusion  (Read 3173 times)

Offline Telsiph

  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
on: September 09, 2008, 01:58:18 AM
Greetings All,

It is indeed very possible that I am not understanding this product, however I figured it would be worth asking even though these forums seems a little dead. I have spent a few hours getting this setup working on my computer and working out the kinks, however a major issue still exists. When watching the video here http://www.youtube.com/watch?v=Jd3-eiid-Uw&eurl=http://www.cs.cmu.edu/~johnny/projects/wii/ , I can see the video camera moving around, however the targets stay still. A 3d effect is created and the targets appear to be moving far beyond the TV creating a 3d effect, which of course is crazy to me. I was able to get my Wiimote connected via bluetooth, and encountered the 64 bit Vista issue where it would not display in full screen. I corrected this by updated all of my DirectX components, and using that code mentioned by Ritesh in the blog post, and recompiling the program. The new EXE now runs, and head tracking works. However the entire screen appears to move with me. The image is bouncy, jerked, and most importantly the background shifts. The entire background shifts and moves in correspondance with how my head (with the sensor bar attached to it) moves. This is very different then the preview videos on youtube, and the demo videos shown. The following are 2 links to pictures showing the calculations the program is giving, plus showing the background altering effect, as opposed to the video feeds which do not show the background moving and instead have the 3d illusion.

http://i9.photobucket.com/albums/a87/Telsiph/NewBitmapImage.jpg

http://i9.photobucket.com/albums/a87/Telsiph/NewBitmapImage2.jpg

The following is the setting I have my config.dat saved to, I have the wiimote balanced on top of my TV, i'm standing a few feet in front of it. The TV is about 23 inches

screenHieght(mm):584.19
sensorBarWidth(mm):215.9
screenAspect(width/height):0
cameraIsAboveScreen(true/false):True
cnnectToSecondWiimote(true/false):False


I am running at 1080p resolution, however dropping it down to default resolutions does not stop this. Please let me know if I am doing something wrong, some tips to correct it, or if perhaps I am misunderstanding what is going on here. I am unsure why a video camera would not see the background shifting, but my eyes would, but any clarification would be most appreciated as I would love to experience this effect more deeply! The current setup has the targets bouncing around and even the entire program taking 5-6 seconds to catch up at times, so any help would be appreciated!



Offline UndCon

  • Support Admin
  • *
  • Posts: 566
  • Karma: +11/-3
    • View Profile
    • UndCon
Reply #1 on: September 09, 2008, 07:06:05 AM
Welcome!

I'm not sure i get your problem as the targets are moving in the video with JL.... so is the grid behind creating the appearance of a 3d-space.

It is supposed to do so...

Regarding your jerky motions I have no clue but I think it has to do with your IRsetup...Mine works just as smooth as JL's


//UndCon